Home / Post /

do i need a new nes emulator for 1.1.4 firmware